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Preparing the Site
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Before you begin, it is a good idea to make a rough sketch of your website.  Planning your pages will help you understand your website hierarchy—how pages will link together.  Drawing out what each page will look like will help you determine the page layout and what elements you want to add.   You can make them as detailed or as simple as you like.  

Create Local Folders

Next, you need to create your local root folder, the folder all your files will be stored in on your computer:
1. Open up ‘My Documents’

2. Go to File > New > Folder
3. Name the folder
4. Open the folder you just created and create a second folder called ‘images’

Note: if you are working on a public computer, make sure to save a copy of your work on another location, such as a flash drive or onto a web server, because these machines get erased frequently.
Define Site

Open Dreamweaver: Start > All Programs > Adobe > Dreamweaver CS3.  If prompted with a dialog box, click Cancel.  On the menu, go to Site > New Site
In Dreamweaver a “site” refers to a location for the documents of a website.  A site allows you to organize and manage all of your web documents, upload them to a web server, track and maintain your links, and manage files.  You should define a site to take full advantage of Dreamweaver features.

There are two locations Dreamweaver asks you to identify when you create a new site:

· Local root folder: Stores the files you’re working on. Dreamweaver refers to this folder as your “local site.” This folder can be on your local computer or it can be on a network server. If you work directly on the server, Dreamweaver uploads files to the server every time you save. 

· Remote folder: Stores your files for testing, production, collaboration, and so on. Dreamweaver refers to this folder as your “remote site” in the Files panel. Typically, your remote folder is on the web server that hosts your website. 
The local and remote folders allow you to transfer files between your computer and your web server.  For a list of places that offer free web hosting, see p. 12 in the appendix.
1. Click the Advanced tab and make sure Local Info is selected under Category
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In the Site Name field, name your web site ‘Basic Web Design’
3. To choose your local root folder, click the yellow folder icon and locate the folder you created.

4. Select the folder, then click Open, then Select
5. To choose your default images folder, click the yellow folder icon and locate the images folder you created

6. Select the folder, then click Open, then Select
7. Do not change any other fields
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Web Server Information

1. Next, click Remote Info under Category
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In the Access field, click on the down arrow [image: image1.bmp]  and select FTP
3. In the FTP Host field type the name of your web server
4. Leave the Host Directory field empty
5. For Login and Password type in your information from your web hosting service Check the box next to Automatically upload files to server on save
6. Click OK
7. If the cache dialog window pops up, click OK
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Click Done to exit the Manage Sites window
[image: image27.png]Site Definition for Basic Web Design

[Basc | Advanced |

Category Local Info

Local root Folder: | C:\My Documentsimy_websitel, [=1
Default images folder: | C:IMy Documentsimy_websitelimages [=]

Testing Server
Cloaking

Design Notes
Ste Hap Layot
File View Columns
Contribute






Workspace Overview
Back in the opening screen, under the Create New section, choose HTML to create a new page.
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Some of the essential elements you use to build your webpage include:

· The Insert bar contains buttons for creating and inserting objects such as tables and images.
· The Document toolbar lets you move between different views of your document, rename the current page, get/put files, preview your page, among other things.
· In the Document window you edit your page in Code view, Design view, or Split (Code and Design).
· Panel groups are groups of panels that can be expanded or collapsed to fit your workspace.  You will mostly use the Files panel to manage your website. 
· The Files panel allows you to view and organize the files in your Dreamweaver site.
· Tag selector is a good tool to precisely select elements in your document, like table rows or cells.
· The Property inspector lets you examine and edit the basic properties of an element you select in your document, such as text or a table.  What you see in the Property inspector changes depending on element you have selected.
Additionally, you can right-click on different elements to access some of these features.

Building the Website

The Homepage

Your homepage is the first page of your site, where your other pages will link from.  In order for Dreamweaver to know which page is your homepage, you must save the file as ‘index.html’:

1. In the menu, go to File > Save (Ctrl+S)
2. In the File name field, replace ‘untitled-1.html’ with ‘index.html’
3. Make sure the folder displayed in the Save in field says ‘my_website’. Then click Save
As you work, is a good habit to save frequently, every 3-5 minutes.
Adding Pages

1. Go to File > New (Ctrl+N)
2. From the Blank Page tab, select HTML as the Page Type
3. If you want a certain kind of layout, choose from the Layout section.  Notice Dreamweaver gives you a preview and brief description of the layout.  If you want a plain page with no layout, select <none>
4. After making your choices, click Create
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Note: you can also create new pages by right-clicking on the page tab on the document toolbar and selecting New, or by right-clicking in the Files panel

Adding Content to Pages

Unless you are familiar with HTML, you will do most of your work in the Design view.  On the Document toolbar, click on the Design view [image: image3.png]4| Design



 button.  You can begin typing the text of your page by clicking anywhere on the page. By default, pages are white and text is Times New Roman in black.  Of course, web pages can be more than black text on a white background.  In the next sections, you will learn how to change the look of your page and add different kinds of content.
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Page Properties

You can set the overall properties of a page by going to Modify > Page Properties on the menu.  In the dialog box that opens, you can set the font, background color or image, link color, and page title, among other things.
You can also change specific elements on a page by selecting them and using the Property inspector at the bottom of the screen.
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1. Start by going to Modify > Page Properties (Ctrl+J)
2. Under the Appearance category, use the down arrows to set the font, size, text color, and background color for the page

3. Next, click Links in the category list

4. Use the down arrows to set the font, style, and size for the all links on the page

5. For links, choose what colors you want the links to be when you:

· see them on the page (Link color)
· move your mouse over them (Rollover links)
· have already clicked on a link (Visited links)
· click on a link (Active Links)

6. If you decide to use special heading styles, click on the Headings category and adjust the styles

7. Under the Title/Encoding category, type the title (the name that will be displayed in the browser window) of the page in the Title field 

8. Click Apply to see the effects on your page, then click OK
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Working with Tables

1. In the menu, go to Insert ( Table, or use the table button [image: image5.bmp] on the insert bar (or Ctrl+Alt+T)

2. Set the table rows, columns, width, and border thickness in the dialog box
3. Click OK
4. When working with tables it is best to use HTML tags to select the part of the table you wish to modify.  For example, to select a row, click in a cell and use the table row <tr> tag on the task bar to select the entire row
5. In the Property inspector, click the small arrow in the lower-right corner to expand the window.  You can now see additional tools to merge and split cells, adjust the cell and border color, and more
Working with Images

To insert images:
1. Click on the Insert image [image: image6.png]


 button on the Insert bar (or Ctrl+Alt+I)
2. In the dialog box, locate your image and select it.  Click OK to insert

3. A window pops up for you to add alternate text (the text displayed when you mouse over an image) for screen reader accessibility.  Type the alternate text and click OK 
When you insert an image, you are actually creating a reference to that image.  Images need to be in your default images folder in order for Dreamweaver to refer to them.  If you insert an image that is not saved in your image folder, Dreamweaver automatically makes a copy in the folder.  You can see a list of images (and all other files of your site) in the files panel. 

Note: If you have already saved or moved your images to your default images folder, you can insert them by simply dragging from the files panel and into your document. 
To edit images:

1. Insert the image into your document

2. Select the image by clicking on it

3. Using the Property inspector you can do basic editing on an image, such as change the size, crop, adjust brightness, and add borders.  Click the expander arrow to see all the tools.  If you have Photoshop installed on your machine, you can edit an image with it by double-clicking on the icon [image: image7.bmp] in the files panel
Image Placeholders
Image placeholders are useful if you do not yet have an image but want to plan your page layout.  To insert image placeholders:

1. Click the down ( arrow on the Insert image [image: image8.png]


 button on the Insert bar
2. In the dialog box, name, choose the size, add alternate text if needed, and color.
3. Click OK
4. Image placeholders can be resized like regular images using the Property inspector.  Notice that the displayed size will change as you resize it
When you are ready to replace an image placeholder with an actual image:
1. Select the image placeholder, then in the Property inspector, click the folder [image: image9.bmp] icon next to the Src text box
2. In the dialog box, navigate to the image you want to replace the image placeholder with and click OK
Linking and Navigation

Once you have set up a site, you need a way to navigate between pages and even other files, such as sound and movie files.  Links can be made from text, images, or objects.  You can use the Point-To-File [image: image10.bmp] icon  and the Property inspector to create links.
Linking to Site Files

Using the Point-To-File icon:

1. Select the text or image you want to turn into a link

2. Click and drag the Point-To-File [image: image11.bmp] icon next to the Link box in the Property inspector and point to the file in the Files panel.  As you drag, notice an arrowed line will follow your cursor as you move to select the file.  In the Link box, you will also see the file name displayed

Using the Property Inspector:

1. Select the text or image you want to turn into a link

2. In the Property inspector, click the folder [image: image12.bmp] icon to the right of the Link box to select a file

3. In the dialog box, browse and select the file.  Click OK
Note: To link to a website or webpage, type the web address in the Link box of the Property inspector.
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Email Links

1. Select the text or image you want to turn into a link

2. In the Link box of the Property inspector, type ‘mailto:’ followed by the email address. Do not type any spaces between the colon and the email address.

3. To add a subject line, type ‘?subject=’ after the email address, and type a subject after the equals sign. Do not type any spaces between the question mark and the end of the email address. For example: ‘mailto:user@scu.edu?subject=Website Inquiry
Hotspots

Hotspots are links that are drawn on an image.  These show up as light blue shapes on top of the image in Dreamweaver, but display as invisible in the browser.
1. In the Property inspector, click on the appropriate Hotspot tool [image: image14.png]ooy




2. Draw the hotspot over the desired location
3. Click OK when the message box appears
4. Back in the Property inspector, add the link by typing it in the Link box, using the Point-To-File [image: image15.bmp] icon, or browsing with the yellow folder 

Managing Files

Use the Files panel to manage your files.  In addition to the steps below, you can right-click on a file icon to create new folders and pages, or upload and download items to and from your web server, and preview a document.  

Putting Files/Uploading

In Dreamweaver, when you want to upload files to your web server, you use the Put Files [image: image16.bmp] button, which is indicated by the blue arrow pointing up.  If you have not already done so, see p. 2 on how to add remote server information. 

1. In the Files panel, click on the site folder (the topmost folder) to upload the entire site, or select a file or groups of files you want to upload
2. With your file(s) selected, click the Put Files [image: image17.bmp] button
3. If you get an error message regarding the server, timing or synchronization, click OK
4. If asked if you want to put the entire site up or get dependent files, click Yes
Getting Files/Downloading

In Dreamweaver, when you want to download files from your web server after you have put them there, you use the Get Files[image: image18.bmp] button, which is indicated by the green arrow pointing down.  This is useful when the server has the most current version of your website, especially if you’re working on a public computer.  Keep reading for more on how to set up and download your website to a public computer.

1. In the Files panel, click on the site folder (the topmost folder) to download the entire site, or select a file or groups of files you want to download
2. With your file(s) selected, click the Get Files [image: image19.bmp] button
3. If asked if you want to get the entire site or dependent files, click Yes
Downloading Your Website to a Public Computer
If you use a public computer to do your work, you will need to download the latest copy every time you use the computer, since your work will get erased.
1. Create a new local root folder.  It is best to create it on the desktop so that it is easy for you to find
1. Define your site.  See p. 2 for complete instructions
2. Note that you will point both the local root folder and the default images folder to the same folder you created on the desktop
3. Enter the web server information.  See p. 3 for complete instructions
4. When entering server information, check the box next to Use Passive FTP
Preview in Browser

You can preview a page in a browser at any time; you don’t have to upload it to a web server first.  Before previewing, make sure you save.  Otherwise, the browser will not show your most recent changes.

1. On the menu, go to File > Preview In Browser, and then select one of the listed browsers (or F12 on the keyboard)
2. Note: If no browsers are listed, select Edit > Preferences and then select the Preview In Browser category on the left to select a browser
3. Click links and test the content in your page.  When you are done, close the browser window
Appendix

Dreamweaver Help Menu

You can always learn more about different tools and capabilities of Dreamweaver using the Help Menu or F1 on your keyboard.  Adobe has developed an extensive help file, which is also available on the web, that explains the concepts and instructions behind webpage editing.

HTML and Tags

HTML stands for Hyper Text Markup Language and is the language that most websites and web pages are written in.  Text is “marked up” with tags, expressions between less than and greater than signs, such as <table>.  When you are working in either the Split View or Code View in Dreamweaver, you will be able to see and edit the HTML of a page.

The following sites provide some basic explanations and tutorials on how to write and edit HTML:

· UC Berkeley:  A Basic Set of HTML Tags http://sunsite.berkeley.edu/Web/basictags.html 
· W3 School: Basic HTML Tags http://www.w3schools.com/html/html_primary.asp
· Page Resource: Basic HTML Tutorial http://www.pageresource.com/html/index2.htm
Importing an HTML Document from Word

You can open documents saved by Microsoft Word as HTML files, and then use the Clean Up Word HTML command to remove the extraneous HTML code generated by Word:
1. Save your Word document as an HTML file under File > Save As 
2. Open the HTML file in Dreamweaver
3. To view the HTML code generated by Word, switch to Code view using the Document toolbar 
4. On the menu, go to Commands > Clean Up Word HTML.  Note: If Dreamweaver is unable to determine which version of Word was used to save the file, select the correct version from the pop‑up menu. 
5. Select (or deselect) options for the cleanup. The preferences you enter are saved as default cleanup settings
6. Dreamweaver applies the cleanup settings to the HTML document and a log of the changes appears (unless you deselected that option in the dialog box)
Importing a Word or Excel Document

You can insert a Word or Excel document into a web page.  When you import a Word or Excel document, Dreamweaver receives the converted HTML and inserts it into your web page.  You can also paste portions of a Word document and preserve the formatting.
1. Open the web page where you want to insert the Word or Excel document
2. Select File > Import > Word Document or File > Import > Excel Document to browse for the document.  You can also drag the to the page where you want the content to appear
3. In the dialog box, select any of the formatting options from the Formatting pop-up menu at the bottom of the dialog box:

· Text Only: Inserts unformatted text. If the original text is formatted, all formatting will be removed. 
· Text With Structure: Inserts text that retains structure, but does not retain basic formatting. For example, you can paste text and retain the structure of paragraphs, lists, and tables, without retaining bold, italics, and other formatting. 
· Text With Structure Plus Basic Formatting: Inserts both structured and simple HTML-formatted text (e.g., paragraphs and tables, as well as text formatted with the b, i, u, strong, em, hr, abbr, or acronym tag). 
· Text With Structure Plus Full Formatting: Inserts text that retains all structure, HTML formatting, and CSS styles. 
· Clean Up Word Paragraph Spacing: Eliminates extra space between paragraphs when you paste your text if you selected Text With Structure or Basic Formatting. 
4. Click Open.  The contents of the Word or Excel document appear in your page
Updating Links Automatically

1. On the menu, go to Edit > Preferences
2. In the dialog box, select General from the category list on the left.
3. In the Document Options section, select either Always or Prompt from the Update Links When Moving Files pop‑up menu
4. Click OK
Free Web Hosting

Free Webhosts (http://www.free-webhosts.com/best-free-webhosts.php) provides reviews and ratings of various web hosting sites.  The following are a few of their recommended places:

· 110mb: http://www.110mb.com/
· FreeHostia: http://www.freehostia.com/free_hosting.html

· 50Webs: http://www.50Webs.com[image: image20.bmp]
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For free web hosting, see p. 12











Site Layout Example Sketch





Read more about HTML on p. 11
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